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1 Welcome

1.1 Introduction

Welcome to PhonePad Admin.  PhonePad requires an administrator to look after management of users
and the PhonePad system.  PhonePad Admin is a tool used by the administrator to perform these
functions.  With PhonePad Admin, the administrator can easily add, edit and delete users, change their
passwords, undelete messages accidentally deleted by users, remove unused messages and repair the
PhonePad database. 

If you have any suggestions on improvements we can make, or if you have ideas on some new features
we could add, please drop us a line at support@cybercom-software.com.  We'd love to hear from you. 

We hope you enjoy using PhonePad.   

Cybercom Software 

2 Getting Started

2.1 Do This First

You should read the section on Setting Up PhonePad before doing anything. 

2.2 Main Window

The main window of PhonePad Admin features menus, a toolbar, a taskbar, a User List, and a status
bar. 
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2.3 Menus

The PhonePad Admin menu bar has 3 menus.  Many of the menu items are also available from the  
toolbarand taskbar. 

File menu           

           
Add User Adds a new PhonePad user.     
        
Edit User Edits the selected PhonePad user.     
        
Delete User Deletes the selected PhonePad user.     

Import Users Imports a batch of users from a CSV or XML file.

Receptionist Access Sets access to user Inboxes for receptionists.
        
Login Mode Sets the login mode for PhonePad users.     
        
Message Forwarding Sets up message forwarding for a user.  Allows messages to be

forwarded to an email address.     
        
Print Prints the contents of the User List.     
        
Exit Exits PhonePad. 
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Tools menu         
        
Start Database Starts the PhonePad database after it has been shutdown.  This is only

for Local Mode.  In Remote Mode you do this by starting the PhonePad
Server (DBServer).     

        
Shutdown Database Shuts down the PhonePad database so maintenance can be performed.

This is only for Local Mode.  In Remote Mode you do this by stopping
the PhonePad Server (DBServer).

        
Undelete Messages Undeletes messages for the selected user.     
        
Archive Messages Archives a selected range of messages from the message database to

an archive database.     
        
View Archive Displays all messages in the archive and allows you to delete or

unarchive them.     
        
Reports Displays a range of reports.     
        
Purge Messages Permanently removes all unused messages from the PhonePad

database.     
        
Repair Database Repairs any corrupted data in the PhonePad database.     
        
Empty Database Completely deletes all data from your PhonePad database.  Warning:

you will LOSE ALL OF YOUR MESSAGES if you use this option.  This
is normally only used if you were evaluating PhonePad with test data
and you wanted to remove it and use real data.

        
Broadcast Message Allows you to broadcast a message to all PhonePad users.  You can

use this to advise them of system maintenance, to logout at a specific
time, or even tell them the pizza has arrived!  Only users that have
PhonePad running will receive the message.

Please note: you may need to open port 12500 on any network routers/
bridges you have to allow UDP connections.

        
Logout Users Select this option to immediately logout all users out of PhonePad.  Any

users running PhonePad will be kicked out within a few seconds, without
any warning.

Please note: you may need to open port 12500 on any network routers/
bridges you have to allow UDP connections.

Refresh User List Forces a refresh of the user list so that all fields are correctly displaying
the current values.
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Help menu         
        
Contents Displays the online help (which you are now viewing)  You can also

press F1.     
        
Support Center Launches the PhonePad Support Center, which allows you to access

all support resources from a central location.

Popup Hints Enables or disables popup hints.  These are little yellow tips that are
displayed when you move the mouse over toolbar buttons.     

        
About Displays information about the application.   
  

2.4 The User List

The User List displays all PhonePad users. 

Username The user's Username.     
        
Admin Indicates whether or not they are a PhonePad administrator.     
        
Receptionist Indicates whether or not they are a Receptionist.     
        
Last Login Indicates the date and time of their last login.     
        
Login Enabled Indicates whether or not the login is enabled.     
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Logged In Indicates whether or not they are currently logged in.     

Hidden Indicates whether or not the username is hidden from recipient lists.

 You can print a copy of this list by clicking on the Print button on the toolbar, or by selecting Print from
the File menu. 

2.5 Toolbar

The Toolbar provides quick and easy access to many of PhonePad's features.  These functions are also
available on the menus and taskbar. 

2.6 Taskbar

The taskbar appears on the left side of the PhonePad Admin main window.  It is an alternative to using
the toolbar and menus.  If you prefer not to see the taskbar you can close it by clicking on the splitter
bar.
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2.7 Status Bar

The Status Bar is divided into 3 sections.  The first section is the main part of the status bar, and it
displays status messages as well as hints (eg. when you move the mouse over the toolbar or menu
items, their function is displayed on the status bar).  The second section displays the current status of
the PhonePad database.  A green light indicates that the database is running, a red light indicates the
database has been shut down.  The third section displays the current date and time. 
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3 Using PhonePad Admin

3.1 Adding a User

You will need to create a PhonePad login ID for each person who intends using the system. 

Click on the Add User button on the toolbar, or select Add User from the File menu. 

1. Enter a User Name.  
2. Enter a Password for the user (they can change this themselves once they have logged in). 
3. Enter the same password in the Confirm field.  The reason for this is to confirm that you typed the

password correctly. 
4. If this person is going to be an administrator, check the Admin box.  Otherwise, leave it unchecked.

 
5. If this person is going to be an receptionist, check the Receptionist box.  Otherwise, leave it

unchecked.  
6. The Login Enabled should normally be checked unless you don't want the user logging in yet.
7. If you don't want the username to appear in user and recipient lists then check the Hidden box.
8. Click the OK button to create the user login.  

Passwords 

If PhonePad users are not logging in using a Username  and Password  (see Login Mode) then a
password is not required. 

Admin Check Box 

There are no special Administrator logins - any user can be an Administrator.  To make a user an
administrator just check the Admin Check Box. 

Receptionist Check Box 
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Normally, users can only check their own Inbox for messages.  This means that they can only see
messages that have been sent to them.  A user can be defined as a Receptionist.  This allows them to
view the Inboxes of other users. 

Login Enabled Check Box 

There may be times when you want to prevent a user from logging in.  There are a number of reasons
why you might do this: 

The person is on leave and you want to make sure no one can use their PhonePad login.  

The person no longer works there but you cannot delete their user login because of referential integrity
(see Deleting a User for more information).  

Other security reasons.  

Hidden Check Box

The Hidden check box allows you to hide usernames from the user and recipient lists that you use for
addressing phone and text messages.  If you don't want the username to appear in these lists then
check this box.  A typical use for this is receptionists or administrators.  You may not need to send
messages to receptionists or administrators.  By hiding their usernames, users won't be able to select
them as recipients for messages.

3.2 Administrators

The function of the PhonePad administrator is to look after the PhonePad system.  There is not really
much to do for an administrator as PhonePad pretty much runs itself.  However, you may be required to
perform the following tasks from time to time: 

Add, edit and delete users.  

Undelete messages for users.  

Set the login mode - you would probably only ever do this once.  

Remove unused messages from the system.  You would probably do this once a month.  

Repair the database.  This is only necessary if errors occur in the database.  This would not normally
happen but can occur if a user's computer crashes or they turn it off without shutting down Windows.  

There is no special administrator login - any user can be nominated as an administrator.  This means
that each administrator can have their own password.   

You will need at least one Administrator for PhonePad.  It is recommended that you have a minimum of
two administrators.  In the event that one of the administrators is away for some reason (eg. sick) there
will be someone around to perform administrative functions. 

A default administrator login is created the first time PhonePad Admin is run.  The username is
called Admin and the password is admin.  This is provided so that you can login to PhonePad Admin
for the first time.  Once you have done this you should either delete this login and create your own with
the Admin attribute set, or change the password. 
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If you accidentally close down PhonePad Admin with no administrators existing in the system, you will
not be able to login to the PhonePad Admin application.  This means there will be no PhonePad
administrators.  If this happens then contact us and we will help you fix the problem.

3.3 Archiving Messages

An alternative to purging messages is to archive them.  Archiving moves messages from the main
message database to a special archive database.  Unlike purging, the messages are not deleted - they
are still available.  You can retrieve them at any time (see Viewing the Archive for more information). 

You have two options when archiving messages:

Only archive message that have been
deleted from Inboxes, Sent folders and
other folders.

As the option suggests, only messages that have already
been deleted by users (in other words messages that are no
longer being used) will be archived.

Archive messages and remove them from
Inboxes, etc.

Selecting this option will results in messages being
automatically deleted from Inboxes and other folders and
moved into the archive.

To archive messages, click on the Archive Messages button on the toolbar, select Archive Messages
from the Tools menu, or click on Archive Messages on the taskbar.  Select a date (or type one in) using
the drop-down calendar, and then click on the Archive button to start the process.  The progress bar
provides an indication of the archiving status. 

All messages prior to the date you select will be archived.  Archiving messages is handy for
organizations that want to keep a record of all telephone messages for a period of time (eg. years). 

Important Information
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When a user deletes a message from their Inbox or another folder, the message isn't actually deleted. 
Although the user can no longer see or access the message, it still exists in the database until the
administrator either purges unused messages or archives them.  Archived messages can still be access
via PhonePad's search feature, however purged messages are permanently deleted and can't be
recovered.

3.4 Automatic Message Forwarding

PhonePad can automatically forward messages to an email address or mobile/cell phone.  While users
can activate this option within PhonePad and In-Out Board, administrators can also activate this option
for users.  This comes in handy if a user forgets to do this.  They can phone the administrator and ask
them to activate or deactivate message forwarding for them. 

To activate Message Forwarding for a user, select their name from the user list and click the Message
Forwarding button on the toolbar, select Message Forwarding from the File menu, or click on Message
Forwarding on the taskbar. 

To have PhonePad forward messages to an email address, check the Send Messages via Email option,
enter one or more valid email addresses, and click OK.

To have PhonePad forward messages to a mobile/cell phone, check the Send Messages via SMS
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option, enter one or more mobile/cell phone numbers, and click OK.

IMPORTANT: For message forwarding to work, you need to install the MessageSender application on
one computer on your network. MessageSender can be installed by your PhonePad installation
program. Complete details are documented in the Installation Manual (INSTALL.PDF), and are also
available in the Frequently Asked Questions section of our online forums.

3.5 Broadcast Messages

This facility allows you to send broadcast messages to all PhonePad users. The messages will be
automatically displayed when they are received and will appear on top of all windows.  Only users that
have PhonePad running will receive the message.

All you need to do is type the message and click the Send button.

Important:  You may need to configure your network to use this facility.  If you have routers or bridges
on your network (or software firewalls such as ZoneAlarm), you may need to open Port 12500 to allow
UDP connections.  If you find that the messages aren't being received by PhonePad users (remember,
they have to be logged in to PhonePad), then the messages are being blocked somewhere.

3.6 Changing Passwords

A user's password can be changed using the Edit User option.  Click on the Edit User button on the
toolbar, or select Edit User from the File  menu. 
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The user's current password is hidden, but you can change it by entering a new password in the 
Password field.  You will also need to enter the same password in the Confirm field (this is to verify that
you entered the password you thought you entered).  Click OK to save the new password. 

3.7 Deleting a User

To delete a user, select a user from the User List and click on the Delete User button on the toolbar,
select Delete User from the File menu, or click on Delete User on the taskbar.  

There are a number of options available when deleting a user.  Select the appropriate option and click
the Delete button.  You will be asked to confirm the deletion. 

Deletion Options
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Delete the user but leave their
messages intact.

The user will be deleted from the system but their messages will
remain in the Inbox, Sent Folder and Private Folders.

Delete the user, as well as their
Inbox and Sent Folder.

All messages in the user's Inbox and Sent Folders will be deleted.
 Messages in their Private folders will not be deleted.

Delete the user, their Inbox, Sent
Folder and Private Folders.

All messages in the user's Inbox, Sent Folder, and Private
Folders will be deleted.  Any messages in Public Folders will not
be deleted.

Important

Run a PhonePad database backup before deleting any users.

3.8 Editing a User

To edit a user, click on the Edit User button on the toolbar, select Edit User from the File menu, or click
on the Edit User button on the taskbar. 

Change the appropriate details and click OK. 

Admin Check Box 

There are no special Administrator logins - any user can be an administrator.  To make a user an
administrator just check the Admin check box. 

Receptionist Check Box 
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Normally, users can only check their own Inbox for messages.  This means that they can only see
messages that have been sent to them.  A user can be defined as a Receptionist.  This allows them to
view the Inboxes of other users. 

Login Enabled Check Box 

There may be times when you want to prevent a user from logging in.  There are a number of reasons
why you might do this: 

   The person is on leave and you want to make sure no one can use their PhonePad login.  

   The person no longer works there but you cannot delete their user login because of referential
integrity (see Deleting a User for more information).  

   Other security reasons.  

Hidden Check Box

The Hidden check box allows you to hide usernames from the user and recipient lists that you use for
addressing phone and text messages.  If you don't want the username to appear in these lists then
check this box.  A typical use for this is receptionists or administrators.  You may not need to send
messages to receptionists or administrators.  By hiding their usernames, users won't be able to select
them as recipients for messages.

3.9 Importing Users

PhonePad Admin includes a facility for importing batches of users, ie. you can import dozens or even
hundreds of users in one go.  It also enables you to update existing users.  For example, you can
update passwords, and Admin and Receptionist status.

To import users, click on the Import Users button on the toolbar, select Import Users from the File
menu, or click on the Import Users button on the taskbar. 

Users can be imported from either a CSV (Comma Separated Value) or an XML file.
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Importing a List of Users

1. Select the File Type:  CSV or XML.

2. Select the Import File by clicking on the ... button

3. If you check the Update Existing Users on Import checkbox, users that already exist in PhonePad will
have their details updated.  If this checkbox is unchecked, the import will ignore any users that exist -
their details won't be updated and they won't be overwritten.

4. Click the Load button to load the user details from the specified file.  This is a good opportunity to
check that the information being imported is correct.

5. Click the Import button to import them into the PhonePad database.

Importing from CSV Files

CSV files should be formatted as follows:

<username>, <password>, <true or false>, <true or false>
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For example:

john, secretpassword, false, false

Passwords can be blank, eg. "".

Importing from XML Files

XML files should be in a specific format.  You can create an example XML file by clicking on the XML
button.  This will create an XML file consisting of the current users in the PhonePad database (minus
their passwords for security reasons).

Example XML file:
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3.10 Label Editor

The built-in Label Editor allows you to customize some of the labels used in phone messages.  It
features a preview of the labels so you can see what they look like as you make changes.  You can
access the Label Editor by selecting Label Editor from the Tools menu.

To edit a label, click in one of the edit boxes, or click on the label itself and the edit box will be
selected. As you change a label, it will also change in the preview part of the window.

There are some things you need to keep in mind when changing the default labels:
The underlying functionality remains the same. Although you can change the text of the label, it
doesn't change how it works. 
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Not all labels can be changed.
Don't make the labels too long as they may not be displayed correctly.
Don't add conflicting accelerator keys. They are defined by using an ampersand (&) before a letter.
If you mess things up you can reset the labels back to their default values.  

Saves the label changes you have made.

Exits without saving any of the changes you have made.

Resets the labels back to their default values. Any changes you have
made will be lost if you click the OK button after selecting this option.

Displays information about this application.

Displays online help (which you are now viewing).

3.11 Location of PhonePad Database

The first time you run PhonePad Admin, you will be prompted to either create a new PhonePad
database or specify the location of an existing database. 

 If you are setting up PhonePad for the first time, you would select "Create database" . 

 Select the appropriate option and then click OK.   

3.12 Login Mode

PhonePad users normally login using a Username and Password.  However, you can also use the
Windows Username as their login ID.  In this case, a password is not required (although it is
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recommended users still be given one). 

User Defined Login Users select the method of login they want (under Preferences in
PhonePad).  Normally, they login via a login dialog that prompts them for
their username and password.     

          
Force Windows Login Users can only login using their Window Username.  On a Windows

network this is their network login name.  
  

Typically, you would only set this option once. 

3.13 Logout Users

By selecting this option from the Tools menu, you can immediately log all users out of PhonePad.  Use
this with caution as the users won't get any warning.  It would be good practice to send them a 
broadcast message before doing this.

Important:  You may need to configure your network to use this facility.  If you have routers or bridges
on your network (or software firewalls such as ZoneAlarm), you may need to open Port 12500 to allow
UDP connections.  If you find that the users aren't being logged out then the logout messages are being
blocked somewhere.

3.14 PhonePad.Ini File

The PhonePad.Ini file is very simple so an alternative way to create it is by using a text editor.  Enter the
following lines exactly as shown below and save the file as PHONEPAD.INI. 

[Settings] 

LoginMode=0

A LoginMode of 0  indicates that users can specify their own login method.  A LoginMode of 1  indicates
that users can only login using the Windows Username. 
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3.15 Print Preview

The Print Preview screen features a message preview area and a toolbar along the top of the screen.

Prints the contents of the preview.

Opens a saved preview.

Saves the preview to a file.

Exports the preview to PDF, RTF or HTML.

Finds text in the preview.

Displays the whole page on the screen.

Fits the preview to page width.

Displays the preview at 100%.

Displays the preview as two pages to a screen.

Allows you to select the zoom view for the preview.

Allows you to change the page orientation and margins

The grab tool allows you to grab the pages and move them 
around.

The zoom tool allows you to vary the zoom view.

Navigation buttons allow you to navigate through multi-page
previews.

Closes the preview.

3.16 Printing the User List

You can print the contents of the User List by clicking on the Print button on the toolbar, by selecting
Print from the File menu, or by clicking on Print on the taskbar. 
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3.17 Purging Messages

When you have been using PhonePad for a while, the database may start to get large.  Although it is
unlikely that you will ever exceed PhonePad's limit of 100 million phone messages, you may want to free
up some disk space from time to time.  This option removes unused messages from the PhonePad
database, ie. messages that are not linked to the Inbox, Sent Messages List, or Personal folders of any
user. 

Click on Purge Messages button on the toolbar, select Purge Messages from the Tools menu, or click
on Purge Messages on the taskbar. 

Click on the Execute button to remove the unused messages. 

Important Note 

Once a message has been purged, it cannot be undeleted.  We recommend you purge messages once
every 6 to 12 months, although this really depends on the number of messages that are added to the
system each month.  Purging messages is certainly not mandatory - you can keep messages in the
system for a long as you like. 

An alternative to purging is archiving.  When you purge a message it is totally removed from the
PhonePad system.  When you archive a message, it is moved out of the main message database into
an archive database, which means you can still access the messages at any time.  

See Archiving Messages for more information. 

3.18 Receptionists

A user designated as a Receptionist can access view Inboxes of other users.  When a receptionist logs
in to PhonePad, a user list appears between the sidebar and the Inbox message list.  By selecting
names from the list, the receptionist can switch between Inboxes.  However, they can only view Inboxes
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they have been give access to via the  Receptionist Accessoption.

3.19 Receptionist Access

Before a receptionist can view the Inbox of another user, they first need to be given access.  This is done
using the Receptionist Access option, which is available by clicking on the Receptionist Access option
on the taskbar, clicking on the Receptionist Access button on the toolbar, or by selecting Receptionist
Access from the File menu.
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The list on the left displays all available PhonePad users.  The selected receptionist can access the
Inboxes of all users appearing  in the right-hand list.

Adds the selected user to the access list.

Removes the selected user from the access list.

Adds all users to the access list.

Removes all users from the access list.

3.20 Repairing the Database

The PhonePad database is very robust.  However, corruption can occur from improper operating system
or application shutdown, eg. turning the PC off while PhonePad is still running.  This option allows you to
repair the database should corruption occur.  Before you can repair the database, you will need to 
shutdown PhonePad. 

Click the Repair Database button on the toolbar, select Repair Database from the Tools menu, or click
on Repair Database on the taskbar.  PhonePad Admin will be shut down and the DBRepair utility will
be run. 
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 Click the Repair button to repair the corrupted records. 

3.21 Reports

The Reports window allows a PhonePad Administrator  to run a range of reports.  To run a report, click
on the Reports button on the toolbar, select a report from the report list, and click Preview. 



Using PhonePad Admin 25

Copyright © 2012 Cybercom Software

Select a report from this list and specify the appropriate date range.  Click Report to display the report.
See Print Preview for information on the report window.
                

3.22 Restarting PhonePad

After PhonePad has been shutdown for maintenance, you will need to start it again before users can
login again. 

Restarting the PhonePad Database in Local Mode

Click on the Start Database button on the toolbar, select Start Database from the Tools menu, or click
on the Start Database button on the taskbar. 
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Click Yes to start the PhonePad database.  The database status indicator on the status bar will change
to green. 

Restarting the PhonePad Database in Remote Mode

Go to the computer the PhonePad Server (DBServer) is running on and open the server window by
double-clicking on the DBServer icon in the system tray.  Alternatively, you can run ServerManager and
start the PhonePad server remotely.

Click on the Start button to start the PhonePad server.

3.23 Shutting Down PhonePad

If you need to repair the PhonePad database, you will first need to shutdown PhonePad.     

Shutting Down the PhonePad Database in Local Mode

Click the Shutdown button on the toolbar, select Shutdown Database from the Tools menu, or click on
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Shutdown Database on the taskbar. 

Click the Yes button to shutdown the PhonePad database.  The database status indicator on the status
bar will change to red and the following message will be displayed: 

All PhonePad users currently logged in will receive a message informing them that PhonePad will shut
down in 5 minutes.  Once this period has expired, any users still logged in will be immediately logged
out of PhonePad. 

 Any user attempting to login while PhonePad is shut down will receive the following message: 
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Shutting Down the PhonePad Database in Remote Mode

Go to the computer the PhonePad Server (DBServer) is running on and open the server window by
double-clicking on the DBServer icon in the system tray.  Alternatively, you can run ServerManager and
shut down the PhonePad server remotely.

Click on the Stop button to shutdown the PhonePad server.  All connections will be terminated.
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3.24 Undeleting Messages

This facility allows administrators to undelete messages that have been deleted from a user's Inbox or
Sent Messages List.  If the messages have been purged since the messages were deleted by the user,
it will not be possible to undelete them. 

Select a user from the User List and click on the Undelete Messages button on the toolbar, select
Undelete Messages from the Tools menu, or click the Undelete Messages button on the taskbar.  A list
of all deleted messages for the selected user will be displayed. 

 Select the messages you want to undelete by putting a check mark in each box in the first column. 
Click the Undelete button to add the messages back to the Inbox or Sent Messages list. 

3.25 Viewing the  Archive

Messages that have been archived can be viewed at any time by using the View Archive option.  All
archived messages will be displayed in a list. 

With this option, you can also Unarchive and Delete messages.   

The Delete option permanently deletes messages from the archive.  This option would be used for
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messages that are no longer required. 

The Unarchive option will move the selected messages back to the appropriate users' Inboxes and Sent
folders.  This option would be used to retrieve messages that a user has a need for. 

 With either option, you first need to select the messages by putting a check mark in the boxes on the
left side of the list.  Then click either the Delete button or Unarchive button.  You will be asked to confirm
your choice. 

 The two buttons at the right hand corner of the window allow you to select or deselect all messages in
the list. 
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