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1

�

Welcome

�

1.1

�

Introduction

Welcome to PhonePad Admin.  PhonePad requires an administrator to look after management of
users and the PhonePad system.  PhonePad Admin is a tool used by the administrator to perform
these functions.  With PhonePad Admin, the administrator can easily add, edit and delete users,
change their passwords, undelete messages accidentally deleted by users, remove unused
messages and repair the PhonePad database. 

Before proceeding any further, you should read Setting Up PhonePad. 

If you have any suggestions on improvements we can make, or if you have ideas on some new
features we could add, please drop us a line at support@cybercom-software.com.  We'd love to hear
from you. 

We hope you enjoy using PhonePad.   

Cybercom Software 

�

2

�

Getting Started

�

2.1

�

Do This First

You should read the section on Setting Up PhonePad before doing anything. 

�

2.2

�

Main Window

The main window of PhonePad Admin features menus, a toolbar, a taskbar, a User List, and a status
bar. 
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�

2.3

�

Menus

The PhonePad Admin menu bar has 3 menus.  Many of the menu items are also available from the  
toolbarand taskbar. 

File menu           
           
Add User Adds a new PhonePad user.     
        
Edit User Edits the selected PhonePad user.     
        
Delete User Deletes the selected PhonePad user.     

Receptionist Access Sets access to user Inboxes for receptionists.
        
Login Mode Sets the login mode for PhonePad users.     
        
Message Forwarding Sets up message forwarding for a user.  Allows messages to be

forwarded to an email address.     
        
Print Prints the contents of the User List.     
        
Exit Exits PhonePad. 
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Tools menu         
        
Start Database Starts the PhonePad database after it has been shutdown.  This is

only for Local Mode.  In Remote Mode you do this by starting the
PhonePad Server (DBServer).     

        
Shutdown Database Shuts down the PhonePad database so maintenance can be

performed.  This is only for Local Mode.  In Remote Mode you do this
by stopping the PhonePad Server (DBServer).

        
Undelete Messages Undeletes messages for the selected user.     
        
Archive Messages Archives a selected range of messages from the message database to

an archive database.     
        
View Archive Displays all messages in the archive and allows you to delete or

unarchive them.     
        
Reports Displays a range of reports.     
        
Purge Messages Permanently removes all unused messages from the PhonePad

database.     
        
Repair Database Repairs any corrupted data in the PhonePad database.     
        
Database Location Allows you to view and/or change the location of the PhonePad

database.  If you change the location, you will need to restart
PhonePad Admin.     

        
Backup Runs DBBackup.     
        
Database Polling When checked, database polling is active in PhonePad.   
  
        
        

Help menu         
        
Contents Displays the online help (which you are now viewing)  You can also

press F1.     
        
Popup Hints Enables or disables popup hints.  These are little yellow tips that are

displayed when you move the mouse over toolbar buttons.     
        
About Displays information about the application.   
  

�

2.4

�

The User List

The User List displays all PhonePad users. 
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Username The user's Username.     
        
Admin Indicates whether or not they are a PhonePad administrator.     
        
Receptionist Indicates whether or not they are a Receptionist.     
        
Last Login Indicates the date and time of their last login.     
        
Login Enabled Indicates whether or not the login is enabled.     
        
Logged In Indicates whether or not they are currently logged in.     

Hidden Indicates whether or not the username is hidden from recipient lists.

 You can print a copy of this list by clicking on the Print button on the toolbar, or by selecting Print
from the File menu. 

�

2.5

�

Toolbar

The Toolbar provides quick and easy access to many of PhonePad's features.  These functions are
also available on the menus and taskbar. 
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�

2.6

�

Taskbar

The taskbar appears on the left side of the PhonePad Admin main window.  It is an alternative to
using the toolbar and menus.  If you prefer not to see the taskbar you can close it by clicking on the
splitter bar.

�

2.7

�

Status Bar

The Status Bar is divided into 3 sections.  The first section is the main part of the status bar, and it
displays status messages as well as hints (eg. when you move the mouse over the toolbar or menu
items, their function is displayed on the status bar).  The second section displays the current status of
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the PhonePad database.  A green light indicates that the database is running, a red light indicates
the database has been shut down.  The third section displays the current date and time. 

�

3

�

Using PhonePad Admin

�

3.1

�

Adding a User

You will need to create a PhonePad login ID for each person who intends using the system. 

Click on the Add User button on the toolbar, or select Add User from the File menu. 

1. Enter a User Name.  
2. Enter a Password for the user (they can change this themselves once they have logged in).  
3. If this person is going to be an administrator, check the Admin box.  Otherwise, leave it

unchecked.  
4. If this person is going to be an receptionist, check the Receptionist box.  Otherwise, leave it

unchecked.  
5. The Login Enabled should normally be checked unless you don't want the user logging in yet.
6. If you don't want the username to appear in user and recipient lists then check the Hidden box.
7. Click the OK button to create the user login.  

Passwords 

If PhonePad users are not logging in using a Username  and Password  (see Login Mode) then a
password is not required.  However, it is recommended that you still give users a password because
it will be required by the new PhonePad WebInbox add-on that is currently under development (for
more details on this please contact us). 
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Admin Check Box 

There are no special Administrator logins - any user can be an Administrator.  To make a user an
administrator just check the Admin Check Box. 

Receptionist Check Box 

Normally, users can only check their own Inbox for messages.  This means that they can only see
messages that have been sent to them.  A user can be defined as a Receptionist.  This allows them
to view the Inboxes of other users. 

Login Enabled Check Box 

There may be times when you want to prevent a user from logging in.  There are a number of reasons
why you might do this: 

The person is on leave and you want to make sure no one can use their PhonePad login.  

The person no longer works there but you cannot delete their user login because of referential
integrity (see Deleting a User for more information).  

Other security reasons.  

Hidden Check Box

The Hidden check box allows you to hide usernames from the user and recipient lists that you use for
addressing phone and text messages.  If you don't want the username to appear in these lists then
check this box.  A typical use for this is receptionists or administrators.  You may not need to send
messages to receptionists or administrators.  By hiding their usernames, users won't be able to select
them as recipients for messages.

�

3.2

�

Administrators

The function of the PhonePad administrator is to look after the PhonePad system.  There is not really
much to do for an administrator as PhonePad pretty much runs itself.  However, you may be required
to perform the following tasks from time to time: 

Add, edit and delete users.  

Undelete messages for users.  

Set the login mode - you would probably only ever do this once.  

Remove unused messages from the system.  You would probably do this once a month.  

Repair the database.  This is only necessary if errors occur in the database.  This would not
normally happen but can occur if a user's computer crashes or they turn it off without shutting down
Windows.  

There is no special administrator login - any user can be nominated as an administrator.  This means
that each administrator can have their own password.   
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You will need at least one Administrator for PhonePad.  It is recommended that you have a minimum
of two administrators.  In the event that one of the administrators is away for some reason (eg. sick)
there will be someone around to perform administrative functions. 

A default administrator login is created the first time PhonePad Admin is run.  The username is
called Admin and the password is admin.  This is provided so that you can login to PhonePad Admin
for the first time.  Once you have done this you should either delete this login and create your own
with the Admin attribute set, or change the password. 

If you accidentally close down PhonePad Admin with no administrators existing in the system, you will
not be able to login to the PhonePad Admin application.  This means there will be no PhonePad
administrators.  If this happens then contact us and we will help you fix the problem.

�

3.3

�

Archiving Messages

An alternative to purging messages is to archive them.  Archiving moves messages from the main
message database to a special archive database.  Unlike purging, the messages not deleted - they
are still available.  You can retrieve them at any time (see Viewing the Archive for more information). 

Only messages that have been deleted from the relevant user's Inboxes and Sent folders can be
archived.  Messages that are still present in Inboxes and Sent folders will be ignored.  To archive
messages, click on the Archive Messages button on the toolbar, select Archive Messages from the
Tools menu, or click on Archive Messages on the taskbar.  Select a date (or type one in) using the
drop-down calendar, and then click on the Archive button to start the process.  The progress bar
provides an indication of the archiving status. 

All messages prior to the date you select will be archived.  Archiving messages is handy for
organizations that want to keep a record of all telephone messages for a period of time (eg. years). 
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�

3.4

�

Changing Passwords

A user's password can be changed using the Edit User option.  Click on the Edit User button on the
toolbar, or select Edit User from the File  menu. 

 The user's current password will be displayed.  Enter a new password and click OK . 

�

3.5

�

Deleting a User

To delete a user, select a user from the User List and click on the Delete User button on the toolbar,
select Delete User from the File menu, or click on Delete User on the taskbar.  

There are a number of options available when deleting a user.  Select the appropriate option and
click the Delete button.  You will be asked to confirm the deletion. 

Deletion Options
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Delete the user but leave their
messages intact.

The user will be deleted from the system but their messages will
remain in the Inbox, Sent Folder and Private Folders.

Delete the user, as well as their
Inbox and Sent Folder.

All messages in the user's Inbox and Sent Folders will be
deleted.  Messages in their Private folders will not be deleted.

Delete the user, their Inbox, Sent
Folder and Private Folders.

All messages in the user's Inbox, Sent Folder, and Private
Folders will be deleted.  Any messages in Public Folders will 
not be deleted.

Important

Run a PhonePad database backup before deleting any users.

�

3.6

�

Editing a User

To edit a user, click on the Edit User button on the toolbar, select Edit User from the File menu, or
click on the Edit User button on the taskbar. 

Change the appropriate details and click OK. 

Admin Check Box 

There are no special Administrator logins - any user can be an administrator.  To make a user an
administrator just check the Admin check box. 

Receptionist Check Box 

Normally, users can only check their own Inbox for messages.  This means that they can only see
messages that have been sent to them.  A user can be defined as a Receptionist.  This allows them
to view the Inboxes of other users. 
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Login Enabled Check Box 

There may be times when you want to prevent a user from logging in.  There are a number of reasons
why you might do this: 

   The person is on leave and you want to make sure no one can use their PhonePad login.  

   The person no longer works there but you cannot delete their user login because of referential
integrity (see Deleting a User for more information).  

   Other security reasons.  

Hidden Check Box

The Hidden check box allows you to hide usernames from the user and recipient lists that you use for
addressing phone and text messages.  If you don't want the username to appear in these lists then
check this box.  A typical use for this is receptionists or administrators.  You may not need to send
messages to receptionists or administrators.  By hiding their usernames, users won't be able to select
them as recipients for messages.

�

3.7

�

Location of PhonePad Database

The first time you run PhonePad Admin, you will be prompted to either create a new PhonePad
database or specify the location of an existing database. 

 If you are setting up PhonePad for the first time, you would select "Create database" . 

 Select the appropriate option and then click OK.   
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�

3.8

�

Login Mode

PhonePad users normally login using a Username and Password.  However, you can also use the
Windows Username as their login ID.  In this case, a password is not required (although it is
recommended users still be given one). 

User Defined Login Users select the method of login they want (under Preferences in
PhonePad).  Normally, they login via a login dialog that prompts them
for their username and password.     

          
Force Windows Login Users can only login using their Window Username.  On a Windows

network this is their network login name.  
  

Typically, you would only set this option once. 

�

3.9

�

Message Forwarding

PhonePad can automatically forward messages to an email address.  While users can activate this
option within PhonePad, administrators can also activate this option for users.  This comes in handy if
a user forgets to do this.  They can phone the administrator and ask them to activate or deactivate
message forwarding for them. 

To activate Message Forwarding for a user, select their name from the user list and click the
Message Forwarding button on the toolbar, select Message Forwarding from the File menu, or click
on Message Forwarding on the taskbar. 
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Check the Send to Email Address box and enter a valid email address.  Then click OK. 

Important Note 

For Message Forwarding to work, SendAgent must be running.  See the SendAgent help file (or the
PhonePad User Manual) for more information. 

�

3.10

�

PhonePad.Ini File

The PhonePad.Ini file is very simple so an alternative way to create it is by using a text editor.  Enter
the following lines exactly as shown below and save the file as PHONEPAD.INI. 

[Settings] 

LoginMode=0

A LoginMode of 0  indicates that users can specify their own login method.  A LoginMode of 1
indicates that users can only login using the Windows Username. 

�

3.11

�

Print Preview

The Print Preview screen features a message preview area and a toolbar along the top of the screen.

Prints the contents of the preview.

Opens a saved preview.
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Saves the preview to a file.

Exports the preview to PDF, RTF or HTML.

Finds text in the preview.

Displays the whole page on the screen.

Fits the preview to page width.

Displays the preview at 100%.

Displays the preview as two pages to a screen.

Allows you to select the zoom view for the preview.

Allows you to change the page orientation and margins

The grab tool allows you to grab the pages and move them 
around.

The zoom tool allows you to vary the zoom view.

Navigation buttons allow you to navigate through multi-page
previews.

Closes the preview.

�

3.12

�

Printing the User List

You can print the contents of the User List by clicking on the Print button on the toolbar, by selecting
Print from the File menu, or by clicking on Print on the taskbar. 

�

3.13

�

Purging Messages

When you have been using PhonePad for a while, the database may start to get large.  Although it is
unlikely that you will ever exceed PhonePad's limit of 100 million phone messages, you may want to
free up some disk space from time to time.  This option removes unused messages from the
PhonePad database, ie. messages that are not linked to the Inbox, Sent Messages List, or Personal
folders of any user. 

Click on Purge Messages button on the toolbar, select Purge Messages from the Tools menu, or click
on Purge Messages on the taskbar. 
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Click on the Execute button to remove the unused messages. 

Important Note 

Once a message has been purged, it cannot be undeleted.  We recommend you purge messages
once every 6 to 12 months, although this really depends on the number of messages that are added
to the system each month.  Purging messages is certainly not mandatory - you can keep messages in
the system for a long as you like. 

An alternative to purging is archiving.  When you purge a message it is totally removed from the
PhonePad system.  When you archive a message, it is moved out of the main message database into
an archive database, which means you can still access the messages at any time.  

See Archiving Messages for more information. 

�

3.14

�

Receptionists

A user designated as a Receptionist can access view Inboxes of other users.  When a receptionist
logs in to PhonePad, a user list appears between the sidebar and the Inbox message list.  By
selecting names from the list, the receptionist can switch between Inboxes.  However, they can only
view Inboxes they have been give access to via the  Receptionist Accessoption.
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�

3.15

�

Receptionist Access

Before a receptionist can view the Inbox of another user, they first need to be given access.  This is
done using the Receptionist Access option, which is available by clicking on the Receptionist Access
option on the taskbar, clicking on the Receptionist Access button on the toolbar, or by selecting
Receptionist Access from the File menu.
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The list on the left displays all available PhonePad users.  The selected receptionist can access the
Inboxes of all users appearing  in the right-hand list.

Adds the selected user to the access list.

Removes the selected user from the access list.

Adds all users to the access list.

Removes all users from the access list.

�

3.16

�

Repairing the Database

The PhonePad database is very robust.  However, corruption can occur from improper operating
system or application shutdown, eg. turning the PC off while PhonePad is still running.  This option
allows you to repair the database should corruption occur.  Before you can repair the database, you
will need to shutdown PhonePad. 

Click the Repair Database button on the toolbar, select Repair Database from the Tools menu, or
click on Repair Database on the taskbar.  PhonePad Admin will be shut down and the DBRepair
utility will be run. 
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 Click the Repair button to repair the corrupted records. 

�

3.17

�

Reports

The Reports window allows a PhonePad Administrator  to run a range of reports.  To run a report,
click on the Reports button on the toolbar, select a report from the report list, and click Preview. 
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Select a report from this list and specify the appropriate date range.  Click Report to display the
report.  See Print Preview for information on the report window.
                

�

3.18

�

Restarting PhonePad

After PhonePad has been shutdown for maintenance, you will need to start it again before users can
login again. 

Restarting the PhonePad Database in Local Mode

Click on the Start Database button on the toolbar, select Start Database from the Tools menu, or click
on the Start Database button on the taskbar. 
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Click Yes to start the PhonePad database.  The database status indicator on the status bar will
change to green. 

Restarting the PhonePad Database in Remote Mode

Go to the computer the PhonePad Server (DBServer) is running on and open the server window by
double-clicking on the DBServer icon in the system tray.  Alternatively, you can run ServerManager
and start the PhonePad server remotely.

Click on the Start button to start the PhonePad server.

�

3.19

�

Setting Up PhonePad

Please read the PhonePad 4 Installation Manual for information on installing and setting up
PhonePad. 

�

3.20

�

Shutting Down PhonePad

If you need to repair the PhonePad database, you will first need to shutdown PhonePad.     



�

Using PhonePad Admin

�

21

�

© 2005 ... Your company

Shutting Down the PhonePad Database in Local Mode

Click the Shutdown button on the toolbar, select Shutdown Database from the Tools menu, or click
on Shutdown Database on the taskbar. 

Click the Yes button to shutdown the PhonePad database.  The database status indicator on the
status bar will change to red and the following message will be displayed: 

All PhonePad users currently logged in will receive a message informing them that PhonePad will
shut down in 5 minutes.  Once this period has expired, any users still logged in will be immediately
logged out of PhonePad. 

 Any user attempting to login while PhonePad is shut down will receive the following message: 
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Shutting Down the PhonePad Database in Remote Mode

Go to the computer the PhonePad Server (DBServer) is running on and open the server window by
double-clicking on the DBServer icon in the system tray.  Alternatively, you can run ServerManager
and shut down the PhonePad server remotely.

Click on the Stop button to shutdown the PhonePad server.  All connections will be terminated.
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�

3.21

�

Undeleting Messages

This facility allows administrators to undelete messages that have been deleted from a user's Inbox
or Sent Messages List.  If the messages have been purged since the messages were deleted by the
user, it will not be possible to undelete them. 

Select a user from the User List and click on the Undelete Messages button on the toolbar, select
Undelete Messages from the Tools menu, or click the Undelete Messages button on the taskbar.  A
list of all deleted messages for the selected user will be displayed. 

 Select the messages you want to undelete by putting a check mark in each box in the first column. 
Click the Undelete button to add the messages back to the Inbox or Sent Messages list. 

�

3.22

�

Viewing the  Archive

Messages that have been archived can be viewed at any time by using the View Archive option.  All
archived messages will be displayed in a list. 

With this option, you can also Unarchive and Delete messages.   

The Delete option permanently deletes messages from the archive.  This option would be used for
messages that are no longer required. 
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The Unarchive option will move the selected messages back to the appropriate users' Inboxes and
Sent folders.  This option would be used to retrieve messages that a user has a need for. 

 With either option, you first need to select the messages by putting a check mark in the boxes on the
left side of the list.  Then click either the Delete button or Unarchive button.  You will be asked to
confirm your choice. 

 The two buttons at the right hand corner of the window allow you to select or deselect all messages
in the list. 

�

4

�

Information

�

4.1

�

Contact Us

Contacting Us By Email     

We provide unlimited FREE support via email.  For support with PhonePad or any of our other
products, please email us at: 

support@cybercom-software.com

If you would like more information about PhonePad or any of our other products, or if you would like
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to talk to us about ordering, please email us at: 

sales@cybercom-software.com

We are dedicated to giving you the very best quality software possible, and we are always looking for
ways we can improve our products.  If you have any suggestions on how we can make our software
better, or new features we can add, please drop us a line at either of the above email addresses. 

Contacting Us By Postal Mail     

You can contact us by normal mail at: 

Cybercom Software 
PO Box 5006 
Chisholm  ACT  2905 
Australia

Web Site    

Visit our Home Page for information on all of our products, downloadable evaluation versions and the
latest upgrades.  There is even some free stuff you are welcome to download.  Enter the following
URL into your web browser: 

      www.cybercom-software.com

Contacting Us By Telephone     

 Our preferred method of support is via email, and you will receive the fastest response using this
method.  However, if you do not have email access you can phone us as detailed below.  Please bear
in mind that we are usually extremely busy on software development so you may have to speak with
our voicemail service.  If you leave a message, we will try to return your call as soon as possible. 
Please take note of the time difference if you are calling from overseas. 

      From within Australia:      (02) 6291 9246 
      International:         (+61-2) 6291 9246

You can reach us from Monday to Friday between 8:00 am and 6:00pm AEST (Australian Eastern
Standard Time).  We are +10 hours GMT. 

�

4.2

�

License Agreement

Software License Agreement 

By installing and/or using PhonePad Admin, you accept the terms and conditions of this license
agreement. 

1. Cybercom Software grants to you a non-exclusive, non-sublicensable, license to use this version
of PhonePad Admin (the "Software"), in binary executable form.  This software is NOT free.  After
a once-only 60 day evaluation period you may not continue to use it unless you have a valid
license file licensed in your name or in the name of your organisation.  In the case of an
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Individual License, only the specified licensee may use the Software.  In the case of a Site
License, the Software may only be used within that organisation.     

2. Title, ownership rights, and intellectual property rights in and to the Software shall remain the
property of Cybercom Software.  You agree to abide by the copyright law and all other applicable
laws of Australia, and international copyright laws.  You acknowledge that the Software in source
code form remains a confidential trade secret of Cybercom Software and therefore you agree not
to modify the Software or attempt to decipher, decompile, disassemble or reverse engineer the
Software.     

3. CYBERCOM SOFTWARE OR ITS SUPPLIERS SHALL NOT BE LIABLE FOR INCIDENTAL,
CONSEQUENTIAL, SPECIAL OR INDIRECT DAMAGES OF ANY SORT, EVEN IF CYBERCOM
SOFTWARE HAS BEEN INFORMED OF THE POSSIBILITY OF SUCH DAMAGES.     

4. If you do not agree to any of the terms and conditions of the license agreement then CEASE USE
OF THE SOFTWARE IMMEDIATELY AND DELETE ALL INSTALLATIONS OF IT FROM ANY
SYSTEM YOU HAVE INSTALLED IT ON.  CONTINUED USE OF THE SOFTWARE INDICATES
THAT YOU DO AGREE TO THE TERMS AND CONDITIONS OF THIS LICENSE AGREEMENT. 
  

For more information about licenses, please contact Cybercom Software (see Contact Us). 

�

4.3

�

Ordering

Our products can be ordered online  from our web site at: www.cybercom-software.com.  Please
check our web site for the latest ordering information (in PhonePad Admin, select About  from the
Help  menu and click on the link).  If you have any difficulty, please contact us. 

Once you have purchased a licence, you will be supplied with a Licence Key File (PHONEPAD4.KEY)
 that will change your copy of PhonePad into a fully licenced product.  There is no need to download
a different copy of PhonePad.  The evaluation version and licenced version are one and the same. 

�

4.4

�

Problems?

Unfortunately, due to the complex nature (and human nature) of many applications, bugs
(undocumented features) are a fact of life.  Although we have gone to great lengths to ensure that
this product is bug-free (if there is such a thing) some inadvertently slip through the net.  If you do
come across any bugs in our software please let us know as soon as possible .   

If you find a bug, it is important that you note any error messages that are displayed and the steps
you went through that led to the problem.  This will help us in trying to reproduce the problem. 

Please report any bugs you may encounter to us (support@cybercom-software.com) and we will give
them our immediate attention.
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�

4.5

�

Support

For information on Support, please see Contact Us. 
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